Aller vers le site forum.dofus.com

No flash

Installation de Dofus 2.0 par paquet debian ou rpm (linux)
198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 19 Novembre 2009 - 13:13:13 | #1
Installation de Dofus 2.0 par paquet debian ou rpm (linux) Bonjour à tous,

Le tutoriel a été déplacé ici :
http://forum.ubuntu-fr.org/viewtopic.php?id=363549

Pour ceux qui ont des distributions ne supportant ni apt ni rpm ( Arch, Gentoo, etc ...) c'est ici (voir mon script message 28) :
http://forum.dofus.com/fr/discussions-tech...ml#entry3202172


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 20 Novembre 2009 - 20:27:48 | #2
J'ai donc ajouté le lien pour le paquet rpm que j'ai testé sous fedora, suse et qui devrait donc normalement fonctionner correctement sur toutes les autres distributions basées sur rpm.
Sinon le changelog :
- Resynchronisation avec les fichiers du dernier DofusInstall.run
- Meilleure détection de l'utilisateur courant dans le script de post-install et meilleure tolérance aux erreurs.

Note à ceux qui ont déjà téléchargé le paquet précédent :
Vous n'êtes pas obligé de réinstaller le paquet.


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 20 Novembre 2009 - 20:44:35 | #3
Citation
Compatibilité MAC et Linux

Nous avons pris du retard dans le développement des versions MAC et Linux du client DOFUS 2.0 et de son « updater » (programme qui met à jour le jeu). Cependant, la compatibilité avec ces systèmes d’exploitation sera opérationnelle pour la sortie du jeu.

En provenance du devblog.
Les problèmes rencontrés récemment avec l'updater depuis deux jours s'expliquent donc.
Les paquets seront donc mis à jour dès la sortie du nouvel updater.


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 26 Novembre 2009 - 12:35:06 | #4
Pour ceux qui veulent quand même tester Dofus 2.0 en attendant la sortie du nouvel updater, vous avez deux méthodes pour le moment :
1) Jouer à Dofus avec wine : très simple mais de gros bug et lag

2) Il faut au préalable avoir installé mon paquet
On va donc utiliser le répertoire d'installation de la version windows pour lancer Dofus par la version linux de Air
Pour ce faire vous devez tout d'abord lancer l'updater windows et attendre que les patchs soient téléchargé.
Une fois cela fini vous allez à l'endroit où le jeu est installé par nautilus ou dolphin (chez moi : /home/yoann/.wine/drive_c/Program\ Files/Dofus\ 2\ Online)
Puis vous renommez le répertoire app en share.
Ensuite vous devez récupérer le répertoire bin que mon paquet a installé (/home/votre_nom/DofusOnline_paquet/) puis le coller dans le répertoire où vous avez renommé app en share.
Pour finir, vous n'avez plus qu'à lancer l'exécutable dans bin pour lancer Dofus.

Bon jeu !


Modérateur héroïque Etouffeur de Koulosse
* * * * Inscrit depuis le 27/11/2008
posté 26 Novembre 2009 - 13:57:52 | #5
Je sais que vous semblez être mu par de bonnes intentions, mais sachez tout de même que nous voyons un peu de travers les fichiers à télécharger qui ne sont pas de source officielle.

Ce n'est pas dans le but de vous freiner ou de vous démotiver. Mais même s'il s'agit de paquets pour Linux et/ou Mac, les paquets personnels proposés ainsi peuvent refermer des éléments qui peuvent être dangereux pour l'utilisateur et/ou son ordinateur (backdoor étant un parfait exemple). Pour éviter ce genre de problème, nous ne pouvons pas laisser pareils liens publiés sur le forum sans avis des administrateurs.

- remarque : si vous avez l'accord d'un administrateur, ces liens seront de nouveau apparents.


Ancien abonné Larve
* Inscrit depuis le 04/04/2007
posté 03 Décembre 2009 - 16:22:12 | #6
Génial ton paquet, par contre tu devrais mettre un topic sur le site de Fedora pour eviter de poiroter...














posté 03 Décembre 2009 - 20:16:51 | #7
Pas de problème pour l'installation cependant lorsque je lance l'udpater :
Citation
L'application n'arrive pas à accéder à Internet. Voulez-vous essayer de définir vos paramètres réseau ?

(ce qui n'arrive pas avec wine)

Édition : Le paquet fonctionne bien avec la version finale?


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 04 Décembre 2009 - 18:51:26 | #8
Comme je n'ai obtenu aucune réponse de Sylfaen je compte recréer ce topic sur le forum ubuntu-fr voire fedora aussi et donc mettre les liens dessus. Je vous tiens au courant.
Je suis aussi en cours de test pour les archi 64 bit mais c'est pas gagné ...

@socratok : J'ai des paquets actualisés déjà en ligne.


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 04 Décembre 2009 - 19:28:22 | #9
Le sujet est déplacé ici : http://forum.ubuntu-fr.org/viewtopic.php?id=363549
J'ai également édité la doc d'ubuntu-fr pour cette occasion : http://doc.ubuntu-fr.org/dofus


posté 05 Décembre 2009 - 11:24:33 | #10
Toujours impossible d'établir une connection, j'ai essayé d'ouvrir les ports spécifiés dans le topic d'install, de le lancer en root, mais rien :s
J'ai Ubuntu 9.10.


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 05 Décembre 2009 - 15:18:48 | #11
Es-tu derrière un proxy et as-tu également vérifier tes par-feu (logiciel et matériel) ?


posté 05 Décembre 2009 - 16:29:46 | #12
Alors j'ai autorisé80,8080,443,5555 en TCP/UDP, via le firewall et la livebox, je ne dois pas être derrière un proxy, je sèche :s


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 05 Décembre 2009 - 17:21:14 | #13
Peux tu me mettre ici le contenu du fichier uplauncher.log qui est situé dans /home/ton_nom/Dofus_Paquet/share ?


posté 05 Décembre 2009 - 17:38:39 | #14
Citation
DEBUG (src/core/Core.cpp:200) ########################### NEW UPLAUNCHER INSTANCE #######################################
INFO (src/core/Core.cpp:210) Version de l'updater: 1.0 - dofus2
DEBUG (src/core/Core.cpp:212) Chemin de l'exe /home/sebris/Dofus_Paquet/share/UpLauncher
DEBUG (src/core/Core.cpp:213) Rep d'execution /home/sebris/Dofus_Paquet/share
DEBUG (src/core/Core.cpp:250) parameters count : 1
DEBUG (src/core/Core.cpp:253) getExeFileDirectory : /home/sebris/Dofus_Paquet/share
DEBUG (src/core/Core.cpp:254) current_path: /home/sebris/Dofus_Paquet/share
DEBUG (src/core/Options.cpp:183) isLangSet : true
INFO (src/core/Core.cpp:472) Downloader launched
DEBUG (src/core/Core.cpp:478) Lancement de reg : reg/bin/Reg
INFO (src/dofus/soundProxy/DofusSoundProxy.cpp:145) Lancement effectif du Thread DofusSoundProxy
INFO (src/io/LocalTcpServer.cpp:38) LocalTcpServer en ecoute sur le port 8080
DEBUG (src/io/LocalTcpServer.cpp:87) Sortie de l'accept
INFO (src/io/LocalTcpServer.cpp:38) LocalTcpServer en ecoute sur le port 8081
DEBUG (src/io/LocalTcpServer.cpp:87) Sortie de l'accept
DEBUG (src/ui/wx/ResourcesManager.cpp:105) Using font : 74 Verdana
DEBUG (src/ui/wx/component/ScrollingPanel.cpp:35) Taille du bouton : 12
DEBUG (src/ui/wx/component/ScrollingPanel.cpp:35) Taille du bouton : 12
DEBUG (src/ui/wx/SkinnedWindow.cpp:102) List news : 0xb5ac8c00 List logs : 0xb51d3a40
TRACE (src/patch/LocalGameConfig.cpp:39) Lecture du games.xml : /home/sebris/Dofus_Paquet/share/games.xml
TRACE (src/core/Core.cpp:781) Fichier de config distant demande : http://dl.ak.ankama.com/games/dofus2/updat...ofus2_empty.xml
INFO (src/net/HttpFtpClient.cpp:333) On telecharge http://dl.ak.ankama.com/games/dofus2/updat...ofus2_empty.xml
DEBUG (src/net/HttpFtpClient.cpp:334) valeur des datas de sortie file: ( - string: 0xbff109f8
DEBUG (src/net/HttpFtpClient.cpp:517) Before perform
DEBUG (src/net/HttpFtpClient.cpp:519) After perform
INFO (src/net/HttpFtpClient.cpp:531) taille du fichier, retour : 0,000000
INFO (src/net/HttpFtpClient.cpp:536) code http retour- : 0
DEBUG (src/net/HttpFtpClient.cpp:539) Before cleanup curl
DEBUG (src/net/HttpFtpClient.cpp:542) After cleanup curl
DEBUG (src/net/HttpFtpClient.cpp:546) Flushing datas
ERROR (src/core/Core.cpp:818) Erreur a la recuperation du fichier de config online : http://dl.ak.ankama.com/games/dofus2/updat...ofus2_empty.xml
DEBUG (src/ui/wx/wxUICore.cpp:131) On force la fermeture de la fenetre principale
DEBUG (src/ui/wx/SkinnedWindow.cpp:255) Envoie d'une commande de fermeture au wxCore
DEBUG (src/ui/wx/wxUICore.cpp:58) Destruction du wxUICore
DEBUG (src/core/Core.cpp:2058) Event recu : UI fermee. On stoppe les DL
DEBUG (src/net/Downloader.cpp:770) Thread du Downloader joignable
DEBUG (src/net/Downloader.cpp:785) Thread du Downloader termine
INFO (src/core/Core.cpp:2415) Free System Mutex
DEBUG (src/io/LocalTcpServer.cpp:20) Destruction d'un LocalTcpServer
DEBUG (src/io/LocalTcpServer.cpp:20) Destruction d'un LocalTcpServer
INFO (src/dofus/soundProxy/DofusSoundProxy.cpp:181) Fin du Thread DofusSoundProxy
DEBUG (src/net/Downloader.cpp:778) Thread du Downloader non joignable


Je n'ai mis que la dernière instance(les autres se terminaient pareil)


posté 05 Décembre 2009 - 17:55:24 | #15
À supprimer : double-post.


posté 05 Décembre 2009 - 17:58:13 | #16
bonsoir, tout d'abord merci pour ce petit paquet qui nous facilite la tache pour nous utilisateurs linux.
J'ai un petit problème avec les bouton dofus_direct et dofus_updater quand je clic dessus rien ne s'ouvre...
voila si vous pouvez m'aider je vous en remercie.
je suis sous mandriva 2008.
bonne soirée et bon jeu !


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 05 Décembre 2009 - 18:08:17 | #17
@zilgrogue
Salut,
Peux-tu me dire ce que tu as comme fichiers dans /home/ton_nom/Dofus_Paquet/share

@socratok
Essaies de redémarrer ton pc au cas ou qu'un port ait été bloqué par une application.
Mais ce que je ne comprend pas c'est que ça passe avec wine ...


posté 05 Décembre 2009 - 18:21:39 | #18
J'ai rebooté, rien lancé avant le lanceur, et ça veut pas >>, je suis connecté en ethernet.
J'ai désactivé l'ipv6, ça pourrait être ça?
En tout cas oui, je vois pas pourquoi ça veut pas alors que wine oui, wine ouvrirait des ports tous seuls?(quoique non faut passer root pour)

Édit : J'ai réussi(en cliquant sur le bouton pour jouer(oui ça pouvait pas marcher puisque le dl ne peut commencer)) à lui faire avouer le motif, l'erreur 30100, avec une petite recherche je me rend compte que le support proposerait aux gens de changer d'antivirus, ce qui me laisse perplexe x)


posté 05 Décembre 2009 - 20:28:12 | #19
j'ai les icones__meta-inf__reg__7z__dofusinvokerswf__game.xml__lauch-dofus.sh__mimetype__uplaucher
voila =)



198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 00:51:37 | #20
Ok donc le problème vient des icônes en elles même. Ce n'est donc pas si grave que ça.

Pour lancer l'updater tu n'as qu'à double cliquer sur le fichier UpLauncher dans le répertoire que je t'avais indiqué.

Sinon mets moi ici ce que te renvoie la commande suivante :
cd $HOME/Bureau; cat Dofus_Updater.desktop

@Socratok :
Ça a marché uniquement quand tu as lancé wine en root?
Sinon peux-tu me renvoyer le résultat d'un ifconfig et de sudo iptables -L


posté 06 Décembre 2009 - 10:13:08 | #21
Bonjour voila ce qu'il me dit :
Citation
[julien@localhost ~]$ cd $HOME/Bureau; cat Dofus_Updater.desktop
#!/usr/bin/env xdg-open
[Desktop Entry]
Name=Dofus_Updater
Comment=<>
GenericName=Dofus_Updater
Exec=/home/julien/Dofus_Paquet/share/UpLauncher
Type=Application
Terminal=false
Icon=/usr/share/icons/dofus-icon-48.png
StartupNotify=true
Categories=Game;
[julien@localhost Bureau]$





posté 06 Décembre 2009 - 11:42:24 | #22
Non non, avec wine ça marche en mode utilisateur.

Citation
ifconfig
eth0 Link encap:Ethernet HWaddr 00:15:58:4c:6e:57
inet adr:192.168.1.11 Bcast:192.168.1.255 Masque:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:4191 erreurs:0 :0 overruns:0 frame:0
TX packets:3450 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:4893197 (4.8 M Octets transmis:723455 (723.4 K
Interruption:19 Adresse de base:0xf200

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:672 erreurs:0 :0 overruns:0 frame:0
TX packets:672 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:41988 (41.9 K Octets transmis:41988 (41.9 K


Citation
sudo iptables -L
[sudo] password for ******:
Chain INPUT (policy DROP)
target prot opt source destination
ufw-before-logging-input all -- anywhere anywhere
ufw-before-input all -- anywhere anywhere
ufw-after-input all -- anywhere anywhere
ufw-after-logging-input all -- anywhere anywhere
ufw-reject-input all -- anywhere anywhere
ufw-track-input all -- anywhere anywhere

Chain FORWARD (policy DROP)
target prot opt source destination
ufw-before-logging-forward all -- anywhere anywhere
ufw-before-forward all -- anywhere anywhere
ufw-after-forward all -- anywhere anywhere
ufw-after-logging-forward all -- anywhere anywhere
ufw-reject-forward all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
ufw-before-logging-output all -- anywhere anywhere
ufw-before-output all -- anywhere anywhere
ufw-after-output all -- anywhere anywhere
ufw-after-logging-output all -- anywhere anywhere
ufw-reject-output all -- anywhere anywhere
ufw-track-output all -- anywhere anywhere

Chain ufw-after-forward (1 references)
target prot opt source destination

Chain ufw-after-input (1 references)
target prot opt source destination
RETURN udp -- anywhere anywhere udp dpt:netbios-ns
RETURN udp -- anywhere anywhere udp dpt:netbios-dgm
RETURN tcp -- anywhere anywhere tcp dpt:netbios-ssn
RETURN tcp -- anywhere anywhere tcp dpt:microsoft-ds
RETURN udp -- anywhere anywhere udp dpt:bootps
RETURN udp -- anywhere anywhere udp dpt:bootpc
RETURN all -- anywhere anywhere ADDRTYPE match dst-type BROADCAST

Chain ufw-after-logging-forward (1 references)
target prot opt source destination

Chain ufw-after-logging-input (1 references)
target prot opt source destination

Chain ufw-after-logging-output (1 references)
target prot opt source destination

Chain ufw-after-output (1 references)
target prot opt source destination

Chain ufw-before-forward (1 references)
target prot opt source destination
ufw-user-forward all -- anywhere anywhere

Chain ufw-before-input (1 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ufw-logging-deny all -- anywhere anywhere state INVALID
DROP all -- anywhere anywhere state INVALID
ACCEPT icmp -- anywhere anywhere icmp destination-unreachable
ACCEPT icmp -- anywhere anywhere icmp source-quench
ACCEPT icmp -- anywhere anywhere icmp time-exceeded
ACCEPT icmp -- anywhere anywhere icmp parameter-problem
ACCEPT icmp -- anywhere anywhere icmp echo-request
ACCEPT udp -- anywhere anywhere udp spt:bootps dpt:bootpc
ufw-not-local all -- anywhere anywhere
ACCEPT all -- 224.0.0.0/4 anywhere



posté 06 Décembre 2009 - 12:06:25 | #23
C'est excellent, beau travail. Par contre je trouve ça dommage que tu sois censuré par les modérateurs.

Un question : c'est moi ou la version zip (la seule que j'aurai pu lancer) n'est pas mise en ligne ? Parce que du coup, je n'ai toujours pas pu gouter à cette nouvelle version.
En plus si j'ai bien compris, le script linux est donné juste par argument marketing. Il ne fonctionne que sur les architectures Intel 32bits, c'est du baclé je trouve.

En tout cas, je le redit, merci pour cette contribution qui rattrape un peu les bourdes d'Ankama.

Et j'attends avec impatience la version 64 bits


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 13:12:14 | #24
Salut,
Pour éviter la "censure", j'ai réécris ce topic sur le forum d'ubuntu-fr (lien un peu plus haut) où la je suis sur qu'il n'y aura pas de problème ...

Sinon, j'ai activé sur mes paquets l'installation sur archi 64 bit à titre expérimental.
L'installation fonctionnera donc c'est sur, l'updater également. Mais c'est au niveau de AIR qu'il risque d'y avoir des problèmes.
Je testerai ça sous peu car je viens de découvrir qu'il est possible d'installer des os 64 bit sur un virtualbox installé sur 32 bit!

EDIT : Il n'y a pas de version zip. Ce n'est pas réalisable car il y a besoin d'installer AIR et les 2 paquets .air de Dofus. (nécessite d'être en root en plus)


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 14:01:45 | #25
@socratok :
On dirait que le par-feu de linux bloque certaines choses. As-tu firestarter ou un truc du genre d'installé ? Au pire on réinitialisera les règles.
Chez moi (par-feu désactivé) :
Code
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination


A mon avis wine n'utilise pas le réseau directement comme l'updater car il centralise tout avec le processus wineserver ce qui explique donc que ça marche avec.


@zilgrogue :
Pourtant le script de postinst a généré un raccourci correct.
Quand tu lances l'updater directement depuis le répertoire d'installation, est-ce que cela fonctionne?


posté 06 Décembre 2009 - 15:12:15 | #26
non pas du tout rien ne ce passe.
quand je lance avec les raccourci l'icône charge en suite rien ne s'ouvre.


posté 06 Décembre 2009 - 16:23:05 | #27
Bon j'ai enlevé ufw(pare feu en lign de commande) et gufw(son interface graphique) et du coup la commande me donne la même chose que toi.
Mais, ça ne marche toujours pas >>
Je suis preneur pour réinitialiser les règles.

J'ai réinitialisé les règles...J'ai le même résultat que toi pour iptables -L et...ça ne marche pas o_o


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 17:32:08 | #28
@ Zilgrogue : Tu ne serais pas en 64 bit par hasard ?
En ce qui concerne cette archi j'ai testé depuis ma machine virtuelle et je n'ai pas encore trouvé de moyen pour faire fonctionner AIR...
Dans ton terminal :
Code
cd $HOME/Dofus_Paquet/share
./UpLauncher

Et dis mois ce que ça renvois.

@Socratok :
As-tu redémarré ?
Vérifies également si tu n'as pas de programmes qui tournent en arrière plan qui pourraient te bloquer le port.
Pour vérifier cela renvois moi le début de la commande netstat -an jusqu'aux sockets unix.


posté 06 Décembre 2009 - 18:33:57 | #29
comment savoir si je suis en 64 bit ?

Citation
[julien@localhost ~]$ cd $HOME/Dofus_Paquet/share
[julien@localhost share]$ ./UpLauncher
./UpLauncher: error while loading shared libraries: liblber-2.4.so.2: cannot open shared object file: No such file or directory
[julien@localhost share]$



198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 18:53:29 | #30
En fait non le problème est ailleurs. Tu dois être en 32 bit.
Pour le résoudre :
sudo apt-get install libldap-2.4-2




posté 06 Décembre 2009 - 21:08:59 | #31
Je dois te mettre quoi, désolé je ne sais pas ce que sont les sockets unix
La commande me renvoie un truc tellement long que ça sort de la taille du terminal


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 21:40:30 | #32
Ok alors mets moi le résultat de ça :
netstat -an | grep -v 'unix'

Ça t'éliminera la partie des sockets unix.


posté 06 Décembre 2009 - 21:44:14 | #33
Citation
netstat -an | grep -v 'unix'
Connexions Internet actives (serveurs et établies)
Proto Recv-Q Send-Q Adresse locale Adresse distante Etat
tcp 0 0 127.0.0.1:7634 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp 0 0 192.168.1.11:33156 193.238.148.199:80 TIME_WAIT
tcp 0 0 127.0.0.1:7634 127.0.0.1:50094 TIME_WAIT
tcp 0 0 192.168.1.11:44938 81.52.140.66:80 ESTABLISHED
tcp 0 0 192.168.1.11:44971 65.54.48.175:1863 ESTABLISHED
udp 0 0 0.0.0.0:59458 0.0.0.0:*
udp 0 0 0.0.0.0:68 0.0.0.0:*
udp 0 0 0.0.0.0:5353 0.0.0.0:*
Sockets du domaine UNIX actives (serveurs et établies)
Proto RefCnt Flags Type State I-Node Chemin


C'est en effet de suite beaucoup plus court x)



198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 22:35:21 | #34
Rien n'utilise les ports tcp 8080 et 8081 pourtant ...
Le problème est donc extérieur à ton pc.
As-tu ouvert ces 2 ports sur ton routeur ?


posté 06 Décembre 2009 - 22:44:47 | #35
8080 mais pas 8081, je savais pas pour celui-ci x)
Après ouverture(TCP/UDP) + redémarrage idem ...

Citation
dofus1 Oui TCP 80 80 192.168.1.11

dofus2 Oui UDP 80 80 192.168.1.11

dofus3 Oui TCP 8080 8080 192.168.1.11

dofus4 Oui UDP 8080 8080 192.168.1.11

dofus5 Oui TCP 5555 5555 192.168.1.11

dofus6 Oui UDP 5555 5555 192.168.1.11

dofus7 Oui TCP 443 443 192.168.1.11

dofus8 Oui UDP 443 443 192.168.1.11

dofus9 Oui TCP 8081 8081 192.168.1.11

dofus10 Oui UDP 8081 8081 192.168.1.11


Voilà tout ce que j'ai ouvert pour Dofus, ça m'agacerait presque à la fin u_u"



198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 06 Décembre 2009 - 22:57:25 | #36
Renvois moi le résultat de ça :
Code
sudo apt-get install nmap
nmap 127.0.0.1



posté 07 Décembre 2009 - 07:09:04 | #37
Apres avoir mis le code que tu ma dit voila ce qu'il ce passe.

Citation
[julien@localhost ~]$ sudo apt-get install libldap-2.4-2
bash: sudo: command not found
[julien@localhost ~]$





198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 07 Décembre 2009 - 09:32:58 | #38
Désolé j'avais zapé que tu étais sous mandriva.
Donc tu vas dans le centre de contrôle mandriva puis tu installes le paquet libldap (pas devel) depuis l'assistant graphique.


posté 07 Décembre 2009 - 18:52:58 | #39
des que je les mis je dois faire quoi ? ^^



posté 07 Décembre 2009 - 19:03:14 | #40



198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 07 Décembre 2009 - 21:04:38 | #41
Tentes de relancer l'updater depuis la ligne de commande avec la commande au dessus.


posté 07 Décembre 2009 - 21:24:34 | #42
Bon je désespère, je vais l'installer sous windows voir si ça passe ou pas(pour être sûr que ça vienne du routeur)


posté 08 Décembre 2009 - 18:55:19 | #43
hum... toujours pas ^^'

Citation
[julien@localhost ~]$ cd $HOME/Dofus_Paquet/share
[julien@localhost share]$ ./UpLauncher
./UpLauncher: error while loading shared libraries: libgio-2.0.so.0: cannot open shared object file: No such file or directory
[julien@localhost share]$



198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 08 Décembre 2009 - 22:06:35 | #44
Tour d'abord au lieu de les faire un par un lol :
cd $HOME/Dofus_Paquet/share; ldd UpLauncher

Puis tu me renvois le résultat de cette commande.

Ensuite, j'ai fait une recherche sur libgio-2.0.so.0 et cela me renvoi sur libglib2.0-0 (sur mon ubuntu). C'est bizarre puisque en général c'est installé d'office sur toutes les distrib.
Vérifies donc si ce dernier paquet est bien installé. Si c'est le cas, tentes de rechercher un paquet qui s'appelle libgio-2.0 ou quelque chose du genre au cas ou que le paquet ait été découpé.

Sinon c'est surement un problème de lien symbolique.



posté 09 Décembre 2009 - 07:04:17 | #45
Citation
[julien@localhost ~]$ cd $HOME/Dofus_Paquet/share; ldd UpLauncher
./UpLauncher: /usr/lib/liblber-2.4.so.2: no version information available (required by ./UpLauncher)
./UpLauncher: /usr/lib/libidn.so.11: no version information available (required by ./UpLauncher)
./UpLauncher: /usr/lib/libldap_r-2.4.so.2: no version information available (required by ./UpLauncher)
./UpLauncher: /lib/i686/libc.so.6: version `GLIBC_2.7' not found (required by ./UpLauncher)
linux-gate.so.1 => (0xffffe000)
libidn.so.11 => /usr/lib/libidn.so.11 (0xb7f45000)
liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0xb7f35000)
libldap_r-2.4.so.2 => /usr/lib/libldap_r-2.4.so.2 (0xb7eea000)
librt.so.1 => /lib/i686/librt.so.1 (0xb7ee1000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0xb7eb2000)
libz.so.1 => /lib/libz.so.1 (0xb7e9f000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb7ad2000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb7a42000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb7a26000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb79f4000)
libgdk_pixbuf-2.0.so.0 =>
/usr/lib/libgdk_pixbuf-2.0.so.0 (0xb79da000)
libgio-2.0.so.0 => not found
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb7998000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb791d000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb78ee000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb78ae000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb78aa000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb78a4000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb77da000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb77d7000)
libSM.so.6 => /usr/lib/libSM.so.6 (0xb77cf000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb77a6000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb7784000)
libdl.so.2 => /lib/libdl.so.2 (0xb777f000)
libm.so.6 => /lib/i686/libm.so.6 (0xb775a000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb766c000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7660000)
libc.so.6 => /lib/i686/libc.so.6 (0xb7520000)
libpthread.so.0 => /lib/i686/libpthread.so.0 (0xb7509000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7405000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb73e4000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb73d1000)
libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb73b7000)
libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0xb7374000)
libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb7211000)
/lib/ld-linux.so.2 (0xb7f86000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0xb7178000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0xb7151000)
libcom_err.so.2 => /lib/libcom_err.so.2 (0xb714e000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0xb7146000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb713c000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb7138000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb7135000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7130000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb70a9000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb709a000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb7090000)
libXi.so.6 => /usr/lib/libXi.so.6 (0xb7087000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb7080000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb7076000)
libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6f41000)
libICE.so.6 => /usr/lib/libICE.so.6 (0xb6f27000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb6f24000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6f1e000)


voila =p


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 09 Décembre 2009 - 21:15:15 | #46
Désolé mais apparemment ta distribution est trop ancienne pour faire tourner l'updater (libc trop vieille).
Ta seule solution si tu veux vraiment jouer à dofus 2.0 est d'upgrader à mandriva 2010.0 ou une autre distribution récente.

Bonne chance à toi.


posté 10 Décembre 2009 - 07:10:41 | #47
bon merci ;-)


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 10 Décembre 2009 - 13:33:56 | #48
Copie de mon message sur le forum ubuntu-fr :

Citation
J'ai donc décidé d'arrêter de fournir AIR dans mes paquets ce qui était contraire à la licence de redistribution.
Les nouveaux paquets contiendront uniquement les fichiers nécessaire pour lancer Dofus et auront comme dépendances les paquets que l'installeur de AIR a installé.

Tout ceux qui ont déjà installé les paquets et qui n'ont aucun problème avec n'ont pas besoin de réinstaller tout.
Pour ceux qui rencontrait des problèmes avec la version 1 de AIR, je vous recommande tout d'abord de désinstaller complètement mes paquets :

sudo aptitude remove dofus2.0 dofus2.0+air1.x

Puis installer AIR par la procédure qui va être expliqué ci-dessus. (suivre le lien en dessous)
Et pour finir, installez le nouveau paquet pour Dofus.


http://forum.ubuntu-fr.org/viewtopic.php?p...116561#p3116561


117
Abonné Araknophobe
* Inscrit depuis le 29/12/2007
posté 13 Décembre 2009 - 14:13:19 | #49
Très gentil de créer ces paquets. Mais j'ai un petit problème. L'installation se déroule très bien mais je ne trouve plus la version 1.29 du jeu ce qui est génant puisque je joue sur Kuri. Merci D'avance.


198
Coculine (Raval)
Ancien abonné Cogneur de Kitsou
* * Inscrit depuis le 09/06/2006
posté 13 Décembre 2009 - 19:09:02 | #50
Salut,
Je ne vois pas comment mes paquets aurait pu te supprimer la 1.29 vu que déjà le nom du paquet est différent et que les chemins d'installations sont complètement différents.
Comment l'as-tu installé ? Par mes paquets ou la voix officielle ?
Et par quel manière lances-tu Dofus 1.29 ?